7
$\begingroup$

As has been noted previously, typing MathJax in answers can significantly cause the page to lag. On my Mac this lag is quite severe, even with only minimal MathJax introduced, making it really irritating (and generally makes me think 'lets just take a screenshot').

On long posts, a hide preview link appears (I noticed this when I've been trying to copy and paste @Orthocresol's character tables ), however it it doesn't show up by default.

Please let us have this feature enabled by default so that the preview can be hidden immediately once one begins typing a post.

$\endgroup$
6
  • 1
    $\begingroup$ I've asked about this on meta, and it was not answered, but I was redirected: meta.stackexchange.com/q/253011/260760 long story short, this is not going to happen. $\endgroup$ Jul 7 '17 at 19:46
  • $\begingroup$ @Martin-マーチン My bad! Shame really, the lag is...not good. If they haven't fixed it since that actual meta post, I guess its a lost cause. $\endgroup$
    – NotEvans.
    Jul 7 '17 at 19:54
  • $\begingroup$ Well, I've been using the workaround from that math post that's linked in the comments to my question. It simply disables math completely with bookmarklets. It's not the nicest workaround, but it helps with the lag. When I was answering that mp2 question, it was almost unbearable... If I find the time, I'm writing an answer next week. $\endgroup$ Jul 7 '17 at 19:59
  • $\begingroup$ Is there a chance the lag issue has anything to do with your hardware? I have a "potato" laptop (Thinkpad x220, 2011, Win10, i5 2520M@2.5 GHz, 8 Gb RAM, OS on SSD) which with both Chrome and Firefox ESR loads some of the heaviest Chemistry.SE posts in about 3..5 s (100 Mbps symmetrical connection) and then there is absolutely no lag or flickering, the scrolling is virtually instant. $\endgroup$
    – andselisk Mod
    Aug 20 '17 at 19:28
  • $\begingroup$ There is a page on GitHub that is somewhat related, but shows decent performance on MBP 2011. Which makes me think that it's eather me being lucky (which I never am:) ), or there is something with your hardware or system configuration that needs improvement. $\endgroup$
    – andselisk Mod
    Aug 20 '17 at 19:29
  • $\begingroup$ @andselisk- possibly. I'm either viewing this on my work iMac (2017) or a MacBook Pro (2015). MacBook definitely struggles more, but no issues with lag generally other than on here :) $\endgroup$
    – NotEvans.
    Aug 20 '17 at 20:13
6
$\begingroup$

I asked about this a while back already: Allow me to disable preview while answering in MathJax enabled sites. The principle outcome of this is: Not going to happen.

However, there are a few things to do. $$\mathbf{T}^{e}{}_{s^t}\mathcal{J}_\mathrm{a^x}$$

  1. Choose a different renderer:

    choose a renderer

  2. If you follow through the link chain of my question you'll come to this answer on math.se telling you to use the bookmarklets from Rob John:

    1. start ChatJax installs MathJax and starts a loop that renders $\LaTeX$ as needed. This is intended for use in chat, where the contents of the page are not static. Reloading the page will stop the loop, so the bookmark needs to be run again.

    2. render MathJax installs MathJax and renders $\LaTeX$ once per execution. This is intended for use on web pages where the contents of the page are static.

    3. rendering off disables MathJax while editing. This is useful when rendering is slow while editing questions and answers.

    4. rendering on enables MathJax after being disabled by rendering off.

  3. I just found a script at stackapps.com which might also help doing stuff: StackExchange MathJax Editing Improvements

    I have not had the chance to test it, but it sounds like a solution.

Good luck and little flickering ;)

$\endgroup$
3
  • $\begingroup$ Option 3 is pretty good - just tested it out $\endgroup$
    – orthocresol Mod
    Jul 20 '17 at 10:30
  • $\begingroup$ @orthocresol unfortunately it clashes with another extension I have installed, so I reverted back to the bookmarks. $\endgroup$ Jul 20 '17 at 10:31
  • 1
    $\begingroup$ Oh, that's a bummer.. Well, as far as I can tell, I guess all three options essentially achieve the same thing (they don't hide the preview but they do stop rendering mathjax) so at least there's something that works. $\endgroup$
    – orthocresol Mod
    Jul 20 '17 at 10:33
0
$\begingroup$

A possible workaround for users of Safari on Mac (I'm sure a Windows variant exists of this) involves 'tricking' the browser into thinking that you're viewing the page on a mobile device (no previews exist on the mobile website, allowing MathJax/Images/all rendering generally to be hidden).

If you have Develop enabled in Safari, the preview can be hidden (all rendering of the text stopped) by going to Develop > User Agent > Safari – iPhone.

Unlike actually trying to use your iPhone to type a post, this has the advantage that you're able to use the keyboard, so is essentially the same as normal except with the preview hidden and the design of the page somewhat modified.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .